IDempiere/Install Prerequisites on Ubuntu

From WikiQSS

Jump to: navigation, search

Table of Contents | Install Prerequisites on Ubuntu | Download the Code

For reference this tutorial is done using the following versions:

  • Ubuntu 11.04 64 bits
  • PostgreSQL 8.4.11
  • Mercurial Client 1.7.5
  • OpenJDK 1.6.0.22
  • Eclipse IDE for Java EE Developers 3.7.2 Indigo
  • Mercurial Eclipse Plugin 1.9.1
  • Buckminster 3.7

But it must work with other versions as well.


Contents

Install Ubuntu

Please refer to http://www.ubuntu.com/download

Install PostgreSQL 8.4.11

iDempiere can also run with Oracle 10G or 11G, and also with PostgreSQL 9.1, but for this tutorial we use postgresql 8.4.11

sudo apt-get install postgresql-8.4

Install Mercurial Client 1.7.5

sudo apt-get install mercurial

Install OpenJDK 1.6.0.22

sudo apt-get install openjdk-6-jdk

Install Eclipse Indigo 3.7.2

Download the corresponding version for your operating system from "Eclipse IDE for Java EE Developers"

For Ubuntu 11.04 64 bits I downloaded from here

On ubuntu the installation of eclipse is just uncompress it and is ready for usage, for the rest of the session let's suppose we uncompressed eclipse on a folder called $ECLIPSE_HOME

The first time you run Eclipse it asks for the workspace folder, at this stage you can use the default workspace - it will be changed later.

Install Mercurial Eclipse Plugin 1.9.1

Following instructions from project: http://www.javaforge.com/project/HGE

  • Open the eclipse just installed
  • Navigate to Help > Install New Software
  • Push the "Add" button
  • Fill Name: Mercurial Eclipse
  • Fill Location: http://cbes.javaforge.com/update
  • OK
  • When the list of packages appears select
    • MercurialEclipse
      • The rest are not required
  • Complete the installation pushing Next .... accepting the license and then Finish

Install Buckminster 3.7

Following instructions from project: http://www.eclipse.org/buckminster/

  • Open the eclipse just installed
  • Navigate to Help > Install New Software
  • Push the "Add" button
  • Fill Name: Buckminster
  • Fill Location: http://download.eclipse.org/tools/buckminster/updates-3.7
  • OK
  • When the list of packages appears select
    • Buckminster - Core
    • Buckminster - Maven support
    • Buckminster - PDE support
      • The rest are not required
  • Complete the installation pushing Next .... accepting the license and then Finish

Now you have your prerequisites ready to receive the iDempiere sources

Personal tools